Every command the editor has, in the order of its menus. A command with no keys is in its menu only. The keys that move around the text — Home, End, Ctrl+Home, Ctrl+←, Page Up — are the text’s own and listed in First steps.
This page is generated from the editor’s command table each time the site is built.
File
| Command |
Keys |
Menu |
| New file |
Ctrl+N |
File › New |
| New whiteboard (.canvas) |
menu only |
File › New |
| Today’s note |
Ctrl+Shift+J |
File › New |
| Open file… |
Ctrl+O |
File |
| Save |
Ctrl+S |
File |
| Save as… |
Ctrl+Shift+S |
File |
| Undo |
Ctrl+Z |
File › Edit |
| Redo |
Ctrl+Y |
File › Edit |
| Cut |
Ctrl+X |
File › Edit |
| Copy |
Ctrl+C |
File › Edit |
| Paste |
Ctrl+V |
File › Edit |
| Paste from history… |
Alt+V |
File › Edit |
| Select all |
Ctrl+A |
File › Edit |
| Find in this file… |
Ctrl+F |
File |
| Find and replace… |
Ctrl+H |
File |
| Export as HTML… |
menu only |
File |
| Format this file |
Ctrl+Shift+I |
File |
| Local history |
menu only |
File |
| Blame this file |
menu only |
File |
| Language… |
menu only |
File |
| View as log |
menu only |
File |
| Show as whiteboard (.canvas) |
menu only |
File |
| Generate or update the backlinks |
menu only |
File |
| Check spelling |
menu only |
File |
| Generate or update the table of contents |
menu only |
File |
| Bold |
Ctrl+B |
File › Emphasis |
| Italic |
Ctrl+I |
File › Emphasis |
| Strikethrough |
Ctrl+Shift+X |
File › Emphasis |
| Formula… |
Ctrl+Shift+L |
File › Emphasis |
| Edit the table in a grid |
Ctrl+Shift+T |
File › Table |
| Insert a table |
menu only |
File › Table |
| Add a row to the table |
menu only |
File › Table |
| Add a column to the table |
menu only |
File › Table |
| Align the table under the cursor |
menu only |
File › Table |
| Colours |
Ctrl+Shift+K |
File |
| Characters and symbols |
Ctrl+Shift+Y |
File |
| How this document is read |
Ctrl+Shift+M |
File |
| The stylesheet this file is rendered with |
menu only |
File › View |
| Open in the heavy preview |
Ctrl+Shift+P |
File › View |
| Paste an image |
Ctrl+Alt+V |
File |
| Preview instead of the text |
Ctrl+Shift+V |
File › View |
| Preview beside the text |
Ctrl+Shift+B |
File › View |
| Outline |
Ctrl+Shift+O |
File › View |
| Wrap long lines |
Alt+Z |
File › View |
| Show invisible characters |
menu only |
File › View |
| Keep this file in favourites |
menu only |
File |
Project
| Command |
Keys |
Menu |
| Find a file by name |
Ctrl+P |
Project |
| Open a folder… |
menu only |
Project |
| Keep this folder in favourites |
menu only |
Project |
| Write the project file (.kaivalya/project.toml) |
menu only |
Project |
| The task board (todo.md) |
menu only |
Project |
| This project’s settings |
menu only |
Project |
| Export the project as HTML… |
menu only |
Project |
| Search the project… |
Ctrl+Shift+F |
Project |
| Explorer |
Ctrl+Shift+E |
Project |
| Show hidden files |
Ctrl+Shift+H |
Project |
| Show ignored files |
Ctrl+Shift+G |
Project |
| Close this document |
Ctrl+W |
Project |
| Close all the documents |
Ctrl+Shift+W |
Project › Close several |
| Close the others |
Ctrl+Alt+W |
Project › Close several |
| Close the ones to the right |
menu only |
Project › Close several |
| Close the ones to the left |
menu only |
Project › Close several |
| Next document |
Ctrl+Tab |
Project |
| Previous document |
Ctrl+Shift+Tab |
Project |
| Keyboard to the next pane |
F6 |
Project |
| Keyboard to the previous pane |
Shift+F6 |
Project |
Editor
| Command |
Keys |
Menu |
| Settings file |
Ctrl+, |
Editor |
| Reset the settings file |
menu only |
Editor |
| New window |
Ctrl+Shift+N |
Editor |
| About Kaivalya Editor |
menu only |
Editor |
| Quit |
Ctrl+Q |
Editor |